summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMichele Calgaro <[email protected]>2024-03-13 12:34:59 +0900
committerMichele Calgaro <[email protected]>2024-03-14 23:36:56 +0900
commit48488e36df3d656d1ecbf8f0bf2ff5f7fe28bec6 (patch)
tree1166282734219bbe92ab1d0503a8d0d873885118 /CMakeLists.txt
parent3a03ef43d4ad32c63e6455354b4d2f6f70a98079 (diff)
downloadabakus-48488e36df3d656d1ecbf8f0bf2ff5f7fe28bec6.tar.gz
abakus-48488e36df3d656d1ecbf8f0bf2ff5f7fe28bec6.zip
Use centralized cmake version
Signed-off-by: Michele Calgaro <[email protected]> (cherry picked from commit 84c135c77562c89519707cdbb4504db54d9fda38)
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt12
1 files changed, 6 insertions, 6 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index e45bebb..9733f87 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -9,7 +9,12 @@
#
#################################################
-cmake_minimum_required( VERSION 3.5 )
+
+##### set project version ########################
+
+include( TDEVersion )
+cmake_minimum_required( VERSION ${TDE_CMAKE_MINIMUM_VERSION} )
+tde_set_project_version( )
##### general package setup #####################
@@ -34,11 +39,6 @@ include( FindPkgConfig )
include( TDEMacros )
-##### set version number ########################
-
-tde_set_project_version( )
-
-
##### setup install paths #######################
include( TDESetupPaths )