summaryrefslogtreecommitdiffstats
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index c27a931..36a4204 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -21,6 +21,7 @@ link_directories(
${TQT_LIBRARY_DIRS}
)
+include( ${CMAKE_SOURCE_DIR}/BisonMacros.cmake )
##### other data ################################
@@ -29,6 +30,8 @@ install( FILES abakusui.rc DESTINATION ${DATA_INSTALL_DIR} )
##### abakus (executable) #######################
+GENERATE_BISON_FLEX_SOURCES("lexer.ll", "", "parser.yy", "-d")
+
if( HAVE_MPFR )
set( MPFR_SOURCES "hmath.cpp number.c" )
set( MPFR_LIBRARIES "mpfr gmp" )