summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt10
1 files changed, 9 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 96d138f..de310d0 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -49,7 +49,7 @@ include( TDESetupPaths )
tde_setup_paths( )
-##### user requested options ####################
+##### user requested modules ####################
option( WITH_ALL_OPTIONS "Enable all optional support" OFF )
option( WITH_ALSA "Enable ALSA support" ON )
@@ -61,6 +61,9 @@ option( WITH_JACK "Enable JACK support" ${WITH_ALL_OPTIONS} )
option( WITH_SNDIO "Enable SNDIO support" OFF )
option( WITH_GCC_VISIBILITY "Enable fvisibility and fvisibility-inlines-hidden" ${WITH_ALL_OPTIONS} )
+option( BUILD_ALL "Build all" ON )
+option( BUILD_DOC "Build doc" ${BUILD_ALL} )
+
##### configure checks
@@ -88,6 +91,11 @@ add_subdirectory( gmcop )
add_subdirectory( qtmcop )
+##### other data ################################
+
+tde_conditional_add_project_docs( BUILD_DOC )
+
+
##### write config.h file #######################
configure_file( config.h.cmake config.h @ONLY )