summaryrefslogtreecommitdiffstats
path: root/pot/Makefile.am
diff options
context:
space:
mode:
authorSlávek Banko <[email protected]>2019-01-09 20:15:15 +0100
committerSlávek Banko <[email protected]>2019-01-11 14:31:48 +0100
commitfc2a264df5071a7febbd14ff5995c3c1d7776a9a (patch)
tree7890e8f7df47190bb0159e8cd6ecb03dce76f499 /pot/Makefile.am
parent4638acbc784819a256941c8132cfb8f21024ecbd (diff)
downloadbibletime-fc2a264df5071a7febbd14ff5995c3c1d7776a9a.tar.gz
bibletime-fc2a264df5071a7febbd14ff5995c3c1d7776a9a.zip
Add CMakeL10n rules.
Update translation template. Signed-off-by: Slávek Banko <[email protected]> (cherry picked from commit f195bc821512f91cb87780f0ff0d99641cf27274)
Diffstat (limited to 'pot/Makefile.am')
-rw-r--r--pot/Makefile.am30
1 files changed, 0 insertions, 30 deletions
diff --git a/pot/Makefile.am b/pot/Makefile.am
deleted file mode 100644
index 7a4c458..0000000
--- a/pot/Makefile.am
+++ /dev/null
@@ -1,30 +0,0 @@
-# make messages.pot
-# the -x is for skipping messages already translated in tdelibs
-
-messages:
- echo Preparing documentation files handbook.pot and howto.pot...
- mkdir -p tmp/
- for XML_FILE in `cd ..; find docs -name "*.docbook"`; do\
- echo " creating temporary POT file tmp/$$XML_FILE.pot";\
- (cd tmp; mkdir -p `dirname $$XML_FILE.pot`; xml2pot ../../$$XML_FILE > $$XML_FILE.pot;)\
- done
- echo merging POT files...
- msgcat --force-po -o handbook.pot `find tmp/docs/handbook -name "*.pot"`
- msgcat --force-po -o howto.pot `find tmp/docs/howto/ -name "*.pot"`
- rm -r ./tmp/
- echo Finished creating handbook.pot and howto.pot.\n
- echo Preparing program messages file messages.pot...
- echo Before we start, run make to generate all the auto-generated .cpp and .h files
- (sleep 5; cd ..; make) #needed for .ui files
- echo Now extract the messages...
- perl ./extractrc ../bibletime/xml/*.rc > ../bibletime/rc-dummy.cpp
- perl ./preparetips ../docs/tips > ../bibletime/tips-dummy.cpp
- $(XGETTEXT) -C -F -L C++ -ki18n -kI18N_NOOP -x `tde-config --prefix`/include/tde/kde.pot `find .. -type f -not -name clanguagemgr.cpp -and -name \*.cpp -or -name \*.h -or -name \*.cc` -o messages.pot
- recode iso8859-1..utf-8 messages.pot
- cp ../bibletime/backend/clanguagemgr.cpp clanguagemgr.cpp
- $(XGETTEXT) --from-code=utf-8 --join-existing -C -F -L C++ -ki18n -kI18N_NOOP -x `tde-config --prefix`/include/tde/kde.pot clanguagemgr.cpp -o messages.pot
- rm clanguagemgr.cpp
- echo Finished creating messages.pot.
-
-
-