summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorSlávek Banko <[email protected]>2021-07-22 18:12:06 +0200
committerSlávek Banko <[email protected]>2021-07-22 18:13:01 +0200
commit34b18a71c176ff8ec33096da4afcf507dd2b412c (patch)
tree72cb4c09a96492f0bf4e1bd204e76c88ead48fd1 /CMakeLists.txt
parent1d1538ef9a176049096deacb13e47c9c58fb1711 (diff)
downloadcodeine-34b18a71c176ff8ec33096da4afcf507dd2b412c.tar.gz
codeine-34b18a71c176ff8ec33096da4afcf507dd2b412c.zip
Use common rules for build and install documentation and translations.
Signed-off-by: Slávek Banko <[email protected]>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt8
1 files changed, 6 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 843d3fb..7a5eca5 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -70,8 +70,12 @@ set( CMAKE_MODULE_LINKER_FLAGS "${CMAKE_MODULE_LINKER_FLAGS} -Wl,--no-undefined"
add_subdirectory( src )
add_subdirectory( misc )
-tde_conditional_add_subdirectory( BUILD_DOC doc )
-tde_conditional_add_subdirectory( BUILD_TRANSLATIONS translations )
+
+
+##### other data ################################
+
+tde_conditional_add_project_docs( BUILD_DOC )
+tde_conditional_add_project_translations( BUILD_TRANSLATIONS )
##### write configure files