summaryrefslogtreecommitdiffstats
path: root/src/utilities/slideshow/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/utilities/slideshow/Makefile.am')
-rw-r--r--src/utilities/slideshow/Makefile.am17
1 files changed, 17 insertions, 0 deletions
diff --git a/src/utilities/slideshow/Makefile.am b/src/utilities/slideshow/Makefile.am
new file mode 100644
index 00000000..5340e80c
--- /dev/null
+++ b/src/utilities/slideshow/Makefile.am
@@ -0,0 +1,17 @@
+METASOURCES = AUTO
+
+INCLUDES = -I$(top_srcdir)/src/digikam \
+ -I$(top_srcdir)/src/libs/dimg \
+ -I$(top_srcdir)/src/libs/dmetadata \
+ -I$(top_srcdir)/src/libs/themeengine \
+ -I$(top_srcdir)/src/libs/threadimageio \
+ $(LIBKDCRAW_CFLAGS) \
+ $(all_includes)
+
+noinst_LTLIBRARIES = libslideshow.la
+
+libslideshow_la_SOURCES = toolbar.cpp slideshow.cpp
+
+libslideshow_la_LDFLAGS = $(all_libraries) $(KDE_RPATH) $(LIB_TQT) -lDCOP $(LIB_TDECORE) $(LIB_TDEUI) -ltdefx $(LIB_TDEIO) -ltdetexteditor
+
+