summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMichele Calgaro <[email protected]>2024-03-15 11:06:09 +0900
committerMichele Calgaro <[email protected]>2024-03-17 17:07:40 +0900
commitfb80993a6811d9fb07681ee7276bda5da2421ef7 (patch)
treed4c7ea4f4af0a2d36236f863a48437afb14b7f95 /CMakeLists.txt
parentb81aca2a8cd4ab3f7c7a32213781dfcf5327072a (diff)
downloaddolphin-fb80993a6811d9fb07681ee7276bda5da2421ef7.tar.gz
dolphin-fb80993a6811d9fb07681ee7276bda5da2421ef7.zip
Use centralized cmake version
Signed-off-by: Michele Calgaro <[email protected]> (cherry picked from commit 4c8da11d03695932882b725be97a44cc7d36fbc9)
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt12
1 files changed, 6 insertions, 6 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 49892df..4606279 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -9,7 +9,12 @@
#
#################################################
-cmake_minimum_required( VERSION 3.5 )
+
+##### set project version ########################
+
+include( TDEVersion )
+cmake_minimum_required( VERSION ${TDE_CMAKE_MINIMUM_VERSION} )
+tde_set_project_version( )
##### general package setup #####################
@@ -33,11 +38,6 @@ include( FindPkgConfig )
include( TDEMacros )
-##### set version number ########################
-
-tde_set_project_version( )
-
-
##### setup install paths #######################
include( TDESetupPaths )