summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorSlávek Banko <[email protected]>2022-09-05 22:31:11 +0200
committerSlávek Banko <[email protected]>2022-09-06 03:53:32 +0200
commit49388bda96cd29b0cdbc9a3a7ddd51a1513dab97 (patch)
treed4bbb384a0d46540b7cec3d40e277344a67e77cf /CMakeLists.txt
parent4c626268c0bd7f548e4c23d22fc3b7d18b2f63cf (diff)
downloadgtk-qt-engine-49388bda96cd29b0cdbc9a3a7ddd51a1513dab97.tar.gz
gtk-qt-engine-49388bda96cd29b0cdbc9a3a7ddd51a1513dab97.zip
Add option WITH_GCC_VISIBILITY.
Fix building with hidden visibility. Signed-off-by: Slávek Banko <[email protected]> (cherry picked from commit 7085e78f62c562846a20b9404795034a3ad66113)
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index f2a0869..25178c7 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -47,6 +47,12 @@ tde_setup_paths( )
set( ENV{PKG_CONFIG_PATH} "${PKG_CONFIG_PATH}:$ENV{PKG_CONFIG_PATH}:${LIB_INSTALL_DIR}/pkgconfig" )
+##### optional stuff
+
+option( WITH_ALL_OPTIONS "Enable all optional support" OFF )
+option( WITH_GCC_VISIBILITY "Enable fvisibility and fvisibility-inlines-hidden" ${WITH_ALL_OPTIONS} )
+
+
##### user requested modules
option( BUILD_ALL "Build all" ON )