summaryrefslogtreecommitdiffstats
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorTimothy Pearson <[email protected]>2012-09-15 15:06:40 -0500
committerTimothy Pearson <[email protected]>2012-09-15 15:06:40 -0500
commit827cba3a39a4afe688bfa848fc7dd7c5899b506f (patch)
treed2fdfc1f057a2fa358dc7f418129e4fedf3678cb /tests/Makefile.am
parent0bb5952228cc19402d90e0adf8c88c7ae4ddfd60 (diff)
downloadgtk3-tqt-engine-827cba3a39a4afe688bfa848fc7dd7c5899b506f.tar.gz
gtk3-tqt-engine-827cba3a39a4afe688bfa848fc7dd7c5899b506f.zip
Add initial interface code skeleton for later development
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am15
1 files changed, 14 insertions, 1 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 9bae1df..50880e2 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -2,7 +2,8 @@ EXTRA_DIST = \
test-widgets.glade
noinst_PROGRAMS = \
- test-widgets
+ test-widgets \
+ test-painter
test_widgets_CFLAGS = \
-I$(top_srcdir) \
@@ -14,4 +15,16 @@ test_widgets_LDADD = \
test_widgets_LDFLAGS = \
$(TDEGTK_LDFLAGS)
+test_painter_SOURCES = test-painter.cpp
+
+test_painter_CXXFLAGS = \
+ -I$(top_srcdir) \
+ $(TDEGTK_CFLAGS)
+
+test_painter_LDADD = \
+ $(TDEGTK_LIBADD)
+
+test_painter_LDFLAGS = \
+ $(TDEGTK_LDFLAGS)
+
# FIXME(Cimi): Figure out what tests must be compiled and add them here.