summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMichele Calgaro <[email protected]>2024-03-15 10:59:40 +0900
committerMichele Calgaro <[email protected]>2024-03-17 11:00:01 +0900
commit148fc9293d9883d97fbdf79720cfd8218cf6989b (patch)
treec78ba1bfb2d46a42815ea336c30b21009b013b82 /CMakeLists.txt
parente6473e544e16ca46e5ca4f5ca8a38b2b7ffb61e3 (diff)
downloadkaffeine-148fc9293d9883d97fbdf79720cfd8218cf6989b.tar.gz
kaffeine-148fc9293d9883d97fbdf79720cfd8218cf6989b.zip
Use centralized cmake version
Signed-off-by: Michele Calgaro <[email protected]>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt11
1 files changed, 5 insertions, 6 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 0e07784..61b273e 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -7,7 +7,11 @@
############################################
-cmake_minimum_required( VERSION 3.5 )
+##### set project version ########################
+
+include( TDEVersion )
+cmake_minimum_required( VERSION ${TDE_CMAKE_MINIMUM_VERSION} )
+tde_set_project_version( )
#### general package setup
@@ -31,11 +35,6 @@ include( CheckCXXSourceCompiles )
include( TDEMacros )
-##### set version number ########################
-
-tde_set_project_version( )
-
-
##### get the system's default path for libraries
tde_save_and_set( CMAKE_INSTALL_PREFIX "/usr" )