summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorSlávek Banko <[email protected]>2022-03-30 18:58:56 +0200
committerSlávek Banko <[email protected]>2022-04-01 04:09:51 +0200
commitafd890f578ae7a9d496b6da376e8e0ad857296d9 (patch)
treea90902b309298ebf987ee32a67ec5b0ffed6f6eb /CMakeLists.txt
parent50f352b37bc93d2ef8fa6832dbb614f4e709b16e (diff)
downloadkaffeine-afd890f578ae7a9d496b6da376e8e0ad857296d9.tar.gz
kaffeine-afd890f578ae7a9d496b6da376e8e0ad857296d9.zip
Change libdvdcss detection to search the default system directory for libraries.
This resolves issue TDE/tde-packaging#113. Signed-off-by: Slávek Banko <[email protected]> (cherry picked from commit a91c7c1df5f039a3611bf0aa320b15f70305e8b3)
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt12
1 files changed, 12 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 850f7dc..e27de43 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -33,6 +33,18 @@ set( CMAKE_MODULE_PATH "${CMAKE_SOURCE_DIR}/cmake/modules" )
include( TDEMacros )
+##### get the system's default path for libraries
+
+tde_save_and_set( CMAKE_INSTALL_PREFIX "/usr" )
+include( GNUInstallDirs OPTIONAL )
+if( CMAKE_INSTALL_LIBDIR )
+ set( SYSTEM_LIBDIR "${CMAKE_INSTALL_LIBDIR}" )
+else( )
+ set( SYSTEM_LIBDIR "lib${LIB_SUFFIX}" )
+endif( )
+tde_restore( CMAKE_INSTALL_PREFIX )
+
+
##### setup install paths
include( TDESetupPaths )