summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt25
1 files changed, 12 insertions, 13 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index da881f3..70489a1 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -43,21 +43,20 @@ tde_setup_paths( )
option( WITH_ALL_OPTIONS "Enable all optional support" OFF )
option( WITH_GCC_VISIBILITY "Enable fvisibility and fvisibility-inlines-hidden" ${WITH_ALL_OPTIONS} )
-
-option( WITH_DPMS "Enable support for dpms" ${WITH_ALL_OPTIONS} )
-option( WITH_XTEST "Enable support for XTest" ${WITH_ALL_OPTIONS} )
-option( WITH_XINERAMA "Enable support for xinerama" ${WITH_ALL_OPTIONS} )
-option( WITH_XCB "Enable support for xcb" ${WITH_ALL_OPTIONS} )
-option( WITH_GSTREAMER "Enable support for gstreamer backend" ${WITH_ALL_OPTIONS} )
-option( WITH_OGGVORBIS "Enable support for oggvorbis" ${WITH_ALL_OPTIONS} )
-option( WITH_LAME "Enable support for lame" ${WITH_ALL_OPTIONS} )
-option( WITH_DVB "Enable support for dvb" ${WITH_ALL_OPTIONS} )
-option( USE_TQT_ONLY "Build with tqt support only" OFF )
-option( WITH_XINIT_WORKAROUND "Enable support for xinit workaround" OFF )
+option( WITH_DPMS "Enable support for dpms" ${WITH_ALL_OPTIONS} )
+option( WITH_XTEST "Enable support for XTest" ${WITH_ALL_OPTIONS} )
+option( WITH_XINERAMA "Enable support for xinerama" ${WITH_ALL_OPTIONS} )
+option( WITH_XCB "Enable support for xcb" ${WITH_ALL_OPTIONS} )
+option( WITH_GSTREAMER "Enable support for gstreamer backend" ${WITH_ALL_OPTIONS} )
+option( WITH_OGGVORBIS "Enable support for oggvorbis" ${WITH_ALL_OPTIONS} )
+option( WITH_LAME "Enable support for lame" ${WITH_ALL_OPTIONS} )
+option( WITH_DVB "Enable support for dvb" ${WITH_ALL_OPTIONS} )
+option( USE_TQT_ONLY "Build with tqt support only" OFF )
+option( WITH_XINIT_WORKAROUND "Enable support for xinit workaround" OFF )
##### user requested modules
-option( BUILD_ALL "Build all" OFF )
+option( BUILD_ALL "Build all" OFF )
option( BUILD_DOC "Build documentation" ${BUILD_ALL} )
option( BUILD_TRANSLATIONS "Build translations" ${BUILD_ALL} )
@@ -79,7 +78,7 @@ set( CMAKE_MODULE_LINKER_FLAGS "${CMAKE_MODULE_LINKER_FLAGS} -Wl,--no-undefined"
##### directories
add_subdirectory( ${PROJECT_NAME} )
-tde_conditional_add_subdirectory( BUILD_DOC doc )
+tde_conditional_add_subdirectory( BUILD_DOC doc )
tde_conditional_add_subdirectory( BUILD_TRANSLATIONS po )