summaryrefslogtreecommitdiffstats
path: root/kbfx-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'kbfx-9999.ebuild')
-rw-r--r--kbfx-9999.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/kbfx-9999.ebuild b/kbfx-9999.ebuild
new file mode 100644
index 0000000..6a8e498
--- /dev/null
+++ b/kbfx-9999.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header
+
+inherit kde eutils subversion
+need-kde 3.3
+
+DESCRIPTION="The SVN Version of the KDE alternative K-Menu KBFX"
+HOMEPAGE="http://www.kbfx.org/"
+ESVN_REPO_URI="svn://anonsvn.kde.org/home/kde/trunk/playground/base/kbfx_plasma"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~ppc ~amd64"
+IUSE="strigi"
+
+DEPEND=">=dev-util/cmake-2.4.2
+ strigi? ( kde-misc/strigi )"
+
+export DESTDIR=${D}
+
+src_compile() {
+ cmake \
+ -DCMAKE_INSTALL_PREFIX:PATH=${KDEDIR} \
+ -DUSE_STRIGI:BOOL=$( use strigi && echo ON || echo OFF ) \
+ . || die
+}