summaryrefslogtreecommitdiffstats
path: root/plugins/recentstuff/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'plugins/recentstuff/CMakeLists.txt')
-rw-r--r--plugins/recentstuff/CMakeLists.txt44
1 files changed, 44 insertions, 0 deletions
diff --git a/plugins/recentstuff/CMakeLists.txt b/plugins/recentstuff/CMakeLists.txt
new file mode 100644
index 0000000..787fbd8
--- /dev/null
+++ b/plugins/recentstuff/CMakeLists.txt
@@ -0,0 +1,44 @@
+SET(libkbfxplasmarecentstuffsrc
+ kbfxplasmarecentstuff.cpp
+ )
+
+FILE(GLOB HEADERS *.h)
+
+IF (NOT USE_KDE4)
+ KDE3_AUTOMOC(${libkbfxplasmarecentstuffsrc})
+
+ ADD_LIBRARY(kbfxplasmarecentstuff SHARED ${libkbfxplasmarecentstuffsrc} )
+ SET_TARGET_PROPERTIES(kbfxplasmarecentstuff
+ PROPERTIES
+ COMPILE_FLAGS ${CMAKE_SHARED_LIBRARY_CXX_FLAGS})
+ # SET_TARGET_PROPERTIES(kbfxplasmarecentstuff PROPERTIES
+ # SOVERSION ${LIB_MAJOR}
+ # VERSION ${APPLICATION_VERSION})
+ TARGET_LINK_LIBRARIES(kbfxplasmarecentstuff
+ kbfxdata
+ ${QT_AND_KDECORE_LIBS}
+ ${KDE3_KIO_LIBRARY}
+ ${KDE3_UI_LIBRARY}
+ ${KDE3_KHTML_LIBRARY}
+ ${M_LIBRARY}
+ )
+
+ KDE3_INSTALL_LIBTOOL_FILE(kbfxplasmarecentstuff ${LIB_INSTALL_DIR}/kbfx/plugins)
+ELSE (NOT USE_KDE4)
+ KDE4_AUTOMOC(${libkbfxplasmarecentstuffsrc})
+
+ KDE4_ADD_LIBRARY(kbfxplasmarecentstuff SHARED ${libkbfxplasmarecentstuffsrc} )
+ TARGET_LINK_LIBRARIES(kbfxplasmarecentstuff
+ kbfxdata
+ ${KDE4_KDECORE_LIBS}
+ ${KDE4_KIO_LIBS}
+ ${KDE4_KDEUI_LIBS}
+ ${KDE4_KHTML_LIBS}
+ ${M_LIBRARY}
+ )
+
+ KDE4_INSTALL_LIBTOOL_FILE(kbfxplasmarecentstuff ${LIB_INSTALL_DIR}/kbfx/plugins)
+ENDIF (NOT USE_KDE4)
+
+INSTALL(TARGETS kbfxplasmarecentstuff DESTINATION ${LIB_INSTALL_DIR}/kbfx/plugins)
+INSTALL(FILES ${HEADERS} DESTINATION ${INCLUDE_INSTALL_DIR}/kbfx/plugins)