summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorSlávek Banko <[email protected]>2018-10-19 02:35:22 +0200
committerSlávek Banko <[email protected]>2018-10-19 13:52:49 +0200
commit77d5afb6c56c05211f79fe1b1656837a854bc650 (patch)
tree9c61133876f51023c4b7b6a3dafcf618e8c007f3 /CMakeLists.txt
parente8e56b0eb136e969c2fec43712d5b76811f48128 (diff)
downloadkbiff-77d5afb6c56c05211f79fe1b1656837a854bc650.tar.gz
kbiff-77d5afb6c56c05211f79fe1b1656837a854bc650.zip
cmake: Add options WITH_SSL and WITH_MLED
Fix test for SSL => is not needed, because is used KSSL from tdelibs Fix test for ASUS Mail LED support in ACPI Signed-off-by: Slávek Banko <[email protected]> (cherry picked from commit 3e2052d2d451a77852c362f6b8812f74f4648739)
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt7
1 files changed, 7 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 3562e3f..06bb19a 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -42,6 +42,8 @@ tde_setup_paths( )
option( WITH_ALL_OPTIONS "Enable all optional support" OFF )
option( WITH_GCC_VISIBILITY "Enable fvisibility and fvisibility-inlines-hidden" ${WITH_ALL_OPTIONS} )
+option( WITH_SSL "Build with SSL (imap4s and pop3s) protocol support" ${WITH_ALL_OPTIONS} )
+option( WITH_MLED "Compile with support for Mail LED on ASUS notebooks" OFF )
##### user requested modules
@@ -51,6 +53,11 @@ option( BUILD_DOC "Build documentation" ${BUILD_ALL} )
option( BUILD_TRANSLATIONS "Build translations" ${BUILD_ALL} )
+##### user defined options #######
+
+set( _PATH_MAILDIR "/var/spool/mail" CACHE STRING "Path for the mail spool" )
+
+
##### configure checks
include( ConfigureChecks.cmake )