summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorSlávek Banko <[email protected]>2021-07-22 11:21:34 +0200
committerSlávek Banko <[email protected]>2021-07-22 11:21:58 +0200
commitd028e4db87dc94990000f2a69a3199705dc783f8 (patch)
treeb42b2189a2f430864646586ee410a942afecd237 /CMakeLists.txt
parentbd74f270ad7a740e96ed2d9b1e88bf388c208d00 (diff)
downloadkbiff-d028e4db87dc94990000f2a69a3199705dc783f8.tar.gz
kbiff-d028e4db87dc94990000f2a69a3199705dc783f8.zip
Use common rules for build and install documentation and translations.
Simplify the structure of the documentation directories. Signed-off-by: Slávek Banko <[email protected]> (cherry picked from commit 3b4b5a1fad7ffa13a3c41162eadb51b01915014d)
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt7
1 files changed, 5 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 105ad88..24d2b86 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -76,10 +76,13 @@ set( CMAKE_MODULE_LINKER_FLAGS "${CMAKE_MODULE_LINKER_FLAGS} -Wl,--no-undefined"
##### directories
add_subdirectory( ${PROJECT_NAME} )
-tde_conditional_add_subdirectory( BUILD_DOC doc )
-tde_conditional_add_subdirectory( BUILD_TRANSLATIONS translations )
+##### other data ################################
+
+tde_conditional_add_project_docs( BUILD_DOC )
+tde_conditional_add_project_translations( BUILD_TRANSLATIONS )
+
##### write configure files