summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in12
1 files changed, 6 insertions, 6 deletions
diff --git a/configure.in b/configure.in
index 45b5bc5..5061cac 100644
--- a/configure.in
+++ b/configure.in
@@ -19,8 +19,13 @@ AC_DEFINE_UNQUOTED(APP_NAME, "$PACKAGE", [ Application name ] )
AC_DEFINE_UNQUOTED(APP_VERSION, "$VERSION", [ Application version as text ])
AC_DEFINE_UNQUOTED(APP_INT_VERSION,$INT_VERSION, [ Application version as integer ])
-dnl Checks for programs.
+# Checks for programs.
+AC_PROG_CC
+AC_PROG_CXX
AC_CHECK_COMPILERS
+AC_ENABLE_SHARED(yes)
+AC_ENABLE_STATIC(no)
+KDE_PROG_LIBTOOL
dnl Check for X and extra X libs needed
AC_PATH_XTRA
@@ -28,11 +33,6 @@ if test "$no_x" = yes; then
AC_MSG_ERROR(You need to have the X11 libraries and headers installed)
fi
-KDE_PROG_LIBTOOL
-AC_ENABLE_SHARED(yes)
-AC_ENABLE_STATIC(no)
-AC_PATH_QT
-
CHMLIBDIR="lib/chmlib"
EXTRA_SUBDIRS=""