summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMichele Calgaro <[email protected]>2024-03-15 10:57:47 +0900
committerMichele Calgaro <[email protected]>2024-03-17 15:48:07 +0900
commitab3e85b96a210294b565e06aead56f69326b0183 (patch)
tree1227a14cd58088fbe369e75639276d2bf256f927 /CMakeLists.txt
parentb4e7fbdb191166bc2e02b235c0a5d45e56ac9540 (diff)
downloadkcmldap-ab3e85b96a210294b565e06aead56f69326b0183.tar.gz
kcmldap-ab3e85b96a210294b565e06aead56f69326b0183.zip
Use centralized cmake version
Signed-off-by: Michele Calgaro <[email protected]> (cherry picked from commit ad4d6ffdbd51ff0c1059cdc0db6ef396f39df411)
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt11
1 files changed, 5 insertions, 6 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index cb74802..850939c 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -7,7 +7,11 @@
############################################
-cmake_minimum_required( VERSION 3.5 )
+##### set project version ########################
+
+include( TDEVersion )
+cmake_minimum_required( VERSION ${TDE_CMAKE_MINIMUM_VERSION} )
+tde_set_project_version( )
#### general package setup
@@ -31,11 +35,6 @@ include( CheckCXXSourceCompiles )
include( TDEMacros )
-##### set version number ########################
-
-tde_set_project_version( )
-
-
##### setup install paths
include( TDESetupPaths )