summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMichele Calgaro <[email protected]>2024-03-15 10:57:58 +0900
committerMichele Calgaro <[email protected]>2024-03-17 15:48:37 +0900
commit1cc6eedc19bfc15c76d9cbcc0332cf9b4ecabeae (patch)
tree6ccdd1fdd6838186530bffeadedd04566415f140 /CMakeLists.txt
parent7f36742a7ad92cc4ce6c9f3d892c40155fb3f93d (diff)
downloadkcmldapcontroller-1cc6eedc19bfc15c76d9cbcc0332cf9b4ecabeae.tar.gz
kcmldapcontroller-1cc6eedc19bfc15c76d9cbcc0332cf9b4ecabeae.zip
Use centralized cmake version
Signed-off-by: Michele Calgaro <[email protected]> (cherry picked from commit cabab08ade30028ac30b817b22bbd3d6a07b6a74)
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt11
1 files changed, 5 insertions, 6 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 8da1a29..50d0917 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -7,7 +7,11 @@
############################################
-cmake_minimum_required( VERSION 3.5 )
+##### set project version ########################
+
+include( TDEVersion )
+cmake_minimum_required( VERSION ${TDE_CMAKE_MINIMUM_VERSION} )
+tde_set_project_version( )
#### general package setup
@@ -31,11 +35,6 @@ include( CheckCXXSourceCompiles )
include( TDEMacros )
-##### set version number ########################
-
-tde_set_project_version( )
-
-
##### setup install paths
include( TDESetupPaths )