summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorgregory guy <[email protected]>2020-05-24 15:22:42 +0200
committerTDE Gitea <[email protected]>2020-05-25 07:04:13 +0000
commitc2754a3424db7da341d1361310644cf612c2af78 (patch)
tree7b5876188d7ad7222f0cba68e99abc780c68eef1 /CMakeLists.txt
parent1a9ab7f55af8f5cb112a4a5b4d5bcc3a2478aa4f (diff)
downloadkcmldapcontroller-c2754a3424db7da341d1361310644cf612c2af78.tar.gz
kcmldapcontroller-c2754a3424db7da341d1361310644cf612c2af78.zip
Drop automake build support.
Add basic cmake build instructions. Delete empty folder doc. Delete empty files NEWS, TODO and ChangeLog. Write basic README file. Signed-off-by: gregory guy <[email protected]>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 4fdee81..9151801 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -41,13 +41,13 @@ tde_setup_paths( )
##### optional stuff
-option( WITH_ALL_OPTIONS "Enable all optional support" OFF )
+option( WITH_ALL_OPTIONS "Enable all optional support" OFF )
option( WITH_GCC_VISIBILITY "Enable fvisibility and fvisibility-inlines-hidden" ${WITH_ALL_OPTIONS} )
##### user requested modules
-option( BUILD_ALL "Build all" ON )
+option( BUILD_ALL "Build all" ON )
option( BUILD_TRANSLATIONS "Build translations" ${BUILD_ALL} )