summaryrefslogtreecommitdiffstats
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorgregory guy <[email protected]>2019-04-03 18:19:30 +0200
committergregory guy <[email protected]>2019-04-05 17:11:45 +0200
commit307a1a53261669dc8d1d2ee031a8927f64ddb27a (patch)
treec7b4aa825a12858f3c4fffc0bc7fda19a9102ca3 /src/CMakeLists.txt
parentf0e9b7cf4f429387055108e3c94b9bfc39c5fba0 (diff)
downloadkcmldapcontroller-307a1a53261669dc8d1d2ee031a8927f64ddb27a.tar.gz
kcmldapcontroller-307a1a53261669dc8d1d2ee031a8927f64ddb27a.zip
conversion to the cmake building system
Signed-off-by: gregory guy <[email protected]>
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt51
1 files changed, 51 insertions, 0 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
new file mode 100644
index 0000000..d061fb2
--- /dev/null
+++ b/src/CMakeLists.txt
@@ -0,0 +1,51 @@
+add_subdirectory( primaryrealmwizard )
+add_subdirectory( secondaryrealmwizard )
+
+include_directories(
+ ${CMAKE_BINARY_DIR}
+ ${CMAKE_CURRENT_BINARY_DIR}
+ ${CMAKE_CURRENT_SOURCE_DIR}
+ ${TDE_INCLUDE_DIR}
+ ${TQT_INCLUDE_DIRS}
+ ${KRB5_INCLUDE_DIRS}
+)
+
+link_directories(
+ ${TQT_LIBRARY_DIRS}
+ ${TDE_LIB_DIR}
+)
+
+
+##### kcm_ldapcontroller (kpart)
+
+tde_add_kpart( kcm_ldapcontroller AUTOMOC
+
+ SOURCES
+ ldapcontrollerconfigbase.ui
+ multimasterreplicationconfigbase.ui
+ ldapcontroller.cpp
+ processingdialog.cpp
+ sha1.cc
+ multimasterreplicationconfigdlg.cpp
+ LINK
+ tdecore-shared
+ tdeio-shared
+ tdeui-shared
+ ${TDELDAP_LIBRARIES}
+ primaryrealmwizard-static
+ secondaryrealmwizard-static
+
+ DEPENDENCIES
+ primaryrealmwizard-static
+ secondaryrealmwizard-static
+
+ DESTINATION ${PLUGIN_INSTALL_DIR}
+)
+
+
+##### other data
+
+install(
+ FILES ldapcontroller.desktop
+ DESTINATION ${XDG_APPS_INSTALL_DIR}
+)