summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorgregory guy <[email protected]>2020-05-24 16:09:10 +0200
committerMichele Calgaro <[email protected]>2020-05-26 13:51:56 +0900
commit4954f705d2185c7a1c124e34b8a08f2ca6548355 (patch)
tree714ac725afd19cb88e266d968f00a174970235f0 /CMakeLists.txt
parent44e08b50646dad04fc4a46f1171034685da14b52 (diff)
downloadkcmldapmanager-4954f705d2185c7a1c124e34b8a08f2ca6548355.tar.gz
kcmldapmanager-4954f705d2185c7a1c124e34b8a08f2ca6548355.zip
Drop automake build support.
Add basic cmake build instructions. Delete empty folder doc. Delete empty files ChangeLog, NEWS and TODO. Write basic README file. Signed-off-by: gregory guy <[email protected]> (cherry picked from commit 38ac3d062ead60ca141194deac677d2299a6e961)
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 3 insertions, 3 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 6da6fff..3e37502 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -41,13 +41,13 @@ tde_setup_paths( )
##### optional stuff
-option( WITH_ALL_OPTIONS "Enable all optional support" OFF )
+option( WITH_ALL_OPTIONS "Enable all optional support" OFF )
option( WITH_GCC_VISIBILITY "Enable fvisibility and fvisibility-inlines-hidden" ${WITH_ALL_OPTIONS} )
##### user requested modules
-option( BUILD_ALL "Build all" ON )
+option( BUILD_ALL "Build all" ON )
option( BUILD_TRANSLATIONS "Build translations" ${BUILD_ALL} )
@@ -73,7 +73,7 @@ set( CMAKE_MODULE_LINKER_FLAGS "${CMAKE_MODULE_LINKER_FLAGS} -Wl,--no-undefined"
##### directories
-add_subdirectory( src )
+add_subdirectory( src )
add_subdirectory( cmdline )
tde_conditional_add_subdirectory( BUILD_TRANSLATIONS po )