summaryrefslogtreecommitdiffstats
path: root/cmdline/CMakeLists.txt
diff options
context:
space:
mode:
authorgregory guy <[email protected]>2019-03-15 10:58:02 +0100
committerSlávek Banko <[email protected]>2019-03-31 12:54:19 +0200
commit922d3cdd719e00dc2f8e3f697a922e6926b4e9bc (patch)
treec01312763dfe7adbbb41e48daa4a345f7c2c0593 /cmdline/CMakeLists.txt
parent36a43831f4bf48eb688499e111f7b86d25abb5fb (diff)
downloadkcmldapmanager-922d3cdd719e00dc2f8e3f697a922e6926b4e9bc.tar.gz
kcmldapmanager-922d3cdd719e00dc2f8e3f697a922e6926b4e9bc.zip
conversion to the cmake building system
Signed-off-by: gregory guy <[email protected]> (cherry picked from commit 67025db14ed3496a7977682e1c5c282e630abc4e)
Diffstat (limited to 'cmdline/CMakeLists.txt')
-rw-r--r--cmdline/CMakeLists.txt31
1 files changed, 31 insertions, 0 deletions
diff --git a/cmdline/CMakeLists.txt b/cmdline/CMakeLists.txt
new file mode 100644
index 0000000..567f381
--- /dev/null
+++ b/cmdline/CMakeLists.txt
@@ -0,0 +1,31 @@
+include_directories(
+ ${CMAKE_BINARY_DIR}
+ ${CMAKE_CURRENT_BINARY_DIR}
+ ${CMAKE_CURRENT_SOURCE_DIR}
+ ${TDE_INCLUDE_DIR}
+ ${TQT_INCLUDE_DIRS}
+ ${TDE_INCLUDE_DIR}/tde
+ ${KRB5_INCLUDE_DIRS}
+)
+
+link_directories(
+ ${TQT_LIBRARY_DIRS}
+ ${TDE_LIB_DIR}
+)
+
+
+##### tdeldapmanager (executable)
+
+tde_add_executable( tdeldapmanager AUTOMOC
+
+ SOURCES
+ main.cpp
+ LINK
+ tdecore-shared
+ tdeui-shared
+ tdeio-shared
+ ${TDELDAP_LIBRARIES}
+ ${KRB5_LIBRARIES}
+
+ DESTINATION ${BIN_INSTALL_DIR}
+)