summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorgregory guy <[email protected]>2020-09-29 09:31:20 +0200
committerMichele Calgaro <[email protected]>2020-09-29 18:17:40 +0900
commit62e72a56efdd899229968eca3e5fc1b6c081f4c2 (patch)
tree007f5da069a7dab0cd6fdb9fafcd058078dc7d9b /CMakeLists.txt
parentce8d02907ad5965089e4f2b3cbc3810ea42fa462 (diff)
downloadkerberostray-62e72a56efdd899229968eca3e5fc1b6c081f4c2.tar.gz
kerberostray-62e72a56efdd899229968eca3e5fc1b6c081f4c2.zip
Drop automake build support.
Add basic cmake build instructions. Delete empty folder doc. Delete empty files NEWS and TODO. Add a README file. Some cosmetics. Signed-off-by: gregory guy <[email protected]> (cherry picked from commit 65d08b5b3cd629d406f8bf1cffa6ea392a93b3b7)
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 5efd53a..d82103a 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -41,13 +41,13 @@ tde_setup_paths( )
##### optional stuff
-option( WITH_ALL_OPTIONS "Enable all optional support" OFF )
+option( WITH_ALL_OPTIONS "Enable all optional support" OFF )
option( WITH_GCC_VISIBILITY "Enable fvisibility and fvisibility-inlines-hidden" ${WITH_ALL_OPTIONS} )
##### user requested modules
-option( BUILD_ALL "Build all" ON )
+option( BUILD_ALL "Build all" ON )
option( BUILD_TRANSLATIONS "Build translations" ${BUILD_ALL} )