summaryrefslogtreecommitdiffstats
path: root/po/CMakeLists.txt
diff options
context:
space:
mode:
authorSlávek Banko <[email protected]>2020-09-29 13:18:02 +0200
committerSlávek Banko <[email protected]>2020-09-29 13:18:02 +0200
commit9dee479bc9198dffb04d8e564ec769f94affeef8 (patch)
treef89ee7ff46f65211718315bd9568113b40c77102 /po/CMakeLists.txt
parent75cc3e6aa607d9b9671efd2aad3882c5ed317bc3 (diff)
downloadkerberostray-9dee479bc9198dffb04d8e564ec769f94affeef8.tar.gz
kerberostray-9dee479bc9198dffb04d8e564ec769f94affeef8.zip
Remove the original translation directory layout.
Signed-off-by: Slávek Banko <[email protected]>
Diffstat (limited to 'po/CMakeLists.txt')
-rw-r--r--po/CMakeLists.txt14
1 files changed, 0 insertions, 14 deletions
diff --git a/po/CMakeLists.txt b/po/CMakeLists.txt
deleted file mode 100644
index 75c89f8..0000000
--- a/po/CMakeLists.txt
+++ /dev/null
@@ -1,14 +0,0 @@
-file( GLOB_RECURSE po_files RELATIVE ${CMAKE_CURRENT_SOURCE_DIR} *.po )
-string( REGEX REPLACE "[ \r\n\t]+" ";" _linguas "$ENV{LINGUAS}" )
-
-foreach( _po ${po_files} )
- get_filename_component( _lang ${_po} NAME_WE )
- if( "${_linguas}" MATCHES "^;*$" OR ";${_linguas};" MATCHES ";${_lang};" )
- if( "${_po}" MATCHES "^([^/]*)/.*" )
- string( REGEX REPLACE "^([^/]*)/.*" "\\1" _component "${_po}" )
- else( )
- set( _component "${PROJECT_NAME}" )
- endif( )
- tde_create_translation( FILES ${_po} LANG ${_lang} OUTPUT_NAME ${_component} )
- endif( )
-endforeach( )