summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMichele Calgaro <[email protected]>2024-03-15 11:02:37 +0900
committerMichele Calgaro <[email protected]>2024-03-17 21:14:35 +0900
commit395594625092ecf940a4e699b556829c78977a4d (patch)
treeac34a2b4c43b04889e5ebb8bb3404f97f90074ee /CMakeLists.txt
parentf0b7ab482cdc4b4f8285eca26d660d19d3085fef (diff)
downloadkile-395594625092ecf940a4e699b556829c78977a4d.tar.gz
kile-395594625092ecf940a4e699b556829c78977a4d.zip
Use centralized cmake version
Signed-off-by: Michele Calgaro <[email protected]> (cherry picked from commit ebabcc51f5f389a617a1dec1ddcff918bc727097)
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt11
1 files changed, 5 insertions, 6 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 3ca1afc..a9ca7a8 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -7,7 +7,11 @@
############################################
-cmake_minimum_required( VERSION 3.5 )
+##### set project version ########################
+
+include( TDEVersion )
+cmake_minimum_required( VERSION ${TDE_CMAKE_MINIMUM_VERSION} )
+tde_set_project_version( )
#### general package setup
@@ -32,11 +36,6 @@ include( CheckCXXSourceCompiles )
include( TDEMacros )
-##### set version number ########################
-
-tde_set_project_version( )
-
-
##### setup install paths
include( TDESetupPaths )