summaryrefslogtreecommitdiffstats
path: root/doc/CMakeLists.txt
diff options
context:
space:
mode:
authorSlávek Banko <[email protected]>2021-07-26 10:31:24 +0200
committerSlávek Banko <[email protected]>2021-07-26 10:31:37 +0200
commit1f64791f997599edd9fdb29e900fa2c9693efc2e (patch)
tree2892e309f74c07b710e10a1771cda7a7ce9b7ff4 /doc/CMakeLists.txt
parent53d1eaed3b1fcc1bfb0a190feced52d47219a8c3 (diff)
downloadkima-1f64791f997599edd9fdb29e900fa2c9693efc2e.tar.gz
kima-1f64791f997599edd9fdb29e900fa2c9693efc2e.zip
Use common rules for build and install documentation and translations.
Signed-off-by: Slávek Banko <[email protected]> (cherry picked from commit 1422c3dc888762e6e7d061ca37f7f1f78a431e63)
Diffstat (limited to 'doc/CMakeLists.txt')
-rw-r--r--doc/CMakeLists.txt34
1 files changed, 0 insertions, 34 deletions
diff --git a/doc/CMakeLists.txt b/doc/CMakeLists.txt
deleted file mode 100644
index f6eec15..0000000
--- a/doc/CMakeLists.txt
+++ /dev/null
@@ -1,34 +0,0 @@
-file( GLOB _dirs RELATIVE ${CMAKE_CURRENT_SOURCE_DIR} * )
-list( REMOVE_ITEM _dirs html man )
-
-string( REGEX REPLACE "[ \r\n\t]+" ";" _linguas "$ENV{LINGUAS}" )
-
-foreach( _dir IN LISTS _dirs )
- if( IS_DIRECTORY ${CMAKE_CURRENT_SOURCE_DIR}/${_dir}
- AND ( "${_dir}" STREQUAL "en" OR
- "${_linguas}" MATCHES "^;*$" OR
- ";${_linguas};" MATCHES ";${_dir};" ))
- file( GLOB _doc_files RELATIVE ${CMAKE_CURRENT_SOURCE_DIR}/${_dir} ${_dir}/*.docbook )
- if( _doc_files )
- list( FIND _doc_files "index.docbook" _find_index )
- if( -1 EQUAL _find_index )
- set( _noindex "NOINDEX" )
- else()
- unset( _noindex )
- endif()
- tde_create_handbook(
- SOURCE_BASEDIR ${_dir}
- ${_noindex}
- LANG ${_dir}
- DESTINATION ${PROJECT_NAME}
- )
- endif()
- endif()
-endforeach()
-
-if( EXISTS ${CMAKE_CURRENT_SOURCE_DIR}/html/CMakeLists.txt )
- add_subdirectory( html )
-endif()
-if( EXISTS ${CMAKE_CURRENT_SOURCE_DIR}/man/CMakeLists.txt )
- add_subdirectory( man )
-endif()