summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMichele Calgaro <[email protected]>2024-03-15 11:04:33 +0900
committerMichele Calgaro <[email protected]>2024-03-17 21:20:27 +0900
commit24b2cecdce07f37d02ae8851c960940f14227f50 (patch)
treec7777d86737244da63876797dee1a7dcf884f389 /CMakeLists.txt
parent3a19fc030f547e2203c3ce66938f2dabfd16bbfa (diff)
downloadkkbswitch-24b2cecdce07f37d02ae8851c960940f14227f50.tar.gz
kkbswitch-24b2cecdce07f37d02ae8851c960940f14227f50.zip
Use centralized cmake version
Signed-off-by: Michele Calgaro <[email protected]> (cherry picked from commit d685b485507436477e463c131c8d679f912e07d1)
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt11
1 files changed, 5 insertions, 6 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index b7c0c5f..1d08c3a 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -7,7 +7,11 @@
############################################
-cmake_minimum_required( VERSION 3.5 )
+##### set project version ########################
+
+include( TDEVersion )
+cmake_minimum_required( VERSION ${TDE_CMAKE_MINIMUM_VERSION} )
+tde_set_project_version( )
#### general package setup
@@ -31,11 +35,6 @@ include( CheckCXXSourceCompiles )
include( TDEMacros )
-##### set version number ########################
-
-tde_set_project_version( )
-
-
##### setup install paths
include( TDESetupPaths )