summaryrefslogtreecommitdiffstats
path: root/doc/CMakeLists.txt
diff options
context:
space:
mode:
authorMavridis Philippe <[email protected]>2021-03-04 21:13:34 +0200
committerMavridis Philippe <[email protected]>2021-03-04 21:13:34 +0200
commit567574ed79dfbeda68dacced1a542431c2e5279d (patch)
treea3029b5d60a2fc69aad2e1b6e1aae7599835003d /doc/CMakeLists.txt
parent341437aeaac9d04f0d95e8828f3b710fb8692fd4 (diff)
downloadklamav-567574ed79dfbeda68dacced1a542431c2e5279d.tar.gz
klamav-567574ed79dfbeda68dacced1a542431c2e5279d.zip
First attempt at documentation.
This relates to issue #16. Signed-off-by: Mavridis Philippe <[email protected]>
Diffstat (limited to 'doc/CMakeLists.txt')
-rw-r--r--doc/CMakeLists.txt35
1 files changed, 1 insertions, 34 deletions
diff --git a/doc/CMakeLists.txt b/doc/CMakeLists.txt
index f6eec15..3a2060f 100644
--- a/doc/CMakeLists.txt
+++ b/doc/CMakeLists.txt
@@ -1,34 +1 @@
-file( GLOB _dirs RELATIVE ${CMAKE_CURRENT_SOURCE_DIR} * )
-list( REMOVE_ITEM _dirs html man )
-
-string( REGEX REPLACE "[ \r\n\t]+" ";" _linguas "$ENV{LINGUAS}" )
-
-foreach( _dir IN LISTS _dirs )
- if( IS_DIRECTORY ${CMAKE_CURRENT_SOURCE_DIR}/${_dir}
- AND ( "${_dir}" STREQUAL "en" OR
- "${_linguas}" MATCHES "^;*$" OR
- ";${_linguas};" MATCHES ";${_dir};" ))
- file( GLOB _doc_files RELATIVE ${CMAKE_CURRENT_SOURCE_DIR}/${_dir} ${_dir}/*.docbook )
- if( _doc_files )
- list( FIND _doc_files "index.docbook" _find_index )
- if( -1 EQUAL _find_index )
- set( _noindex "NOINDEX" )
- else()
- unset( _noindex )
- endif()
- tde_create_handbook(
- SOURCE_BASEDIR ${_dir}
- ${_noindex}
- LANG ${_dir}
- DESTINATION ${PROJECT_NAME}
- )
- endif()
- endif()
-endforeach()
-
-if( EXISTS ${CMAKE_CURRENT_SOURCE_DIR}/html/CMakeLists.txt )
- add_subdirectory( html )
-endif()
-if( EXISTS ${CMAKE_CURRENT_SOURCE_DIR}/man/CMakeLists.txt )
- add_subdirectory( man )
-endif()
+tde_auto_add_subdirectories( ) \ No newline at end of file