summaryrefslogtreecommitdiffstats
path: root/src/sqlite/Makefile.am
diff options
context:
space:
mode:
authorMavridis Philippe <[email protected]>2021-01-13 19:26:24 +0200
committerMavridis Philippe <[email protected]>2021-01-13 19:26:24 +0200
commit8c20dc919f7d54eb48fb60f39ba5e1d466a70763 (patch)
tree44d89f278d5dd066603e5ab9c0b270bc8eb4ad51 /src/sqlite/Makefile.am
downloadklamav-8c20dc919f7d54eb48fb60f39ba5e1d466a70763.tar.gz
klamav-8c20dc919f7d54eb48fb60f39ba5e1d466a70763.zip
Initial commit
Signed-off-by: Mavridis Philippe <[email protected]>
Diffstat (limited to 'src/sqlite/Makefile.am')
-rw-r--r--src/sqlite/Makefile.am52
1 files changed, 52 insertions, 0 deletions
diff --git a/src/sqlite/Makefile.am b/src/sqlite/Makefile.am
new file mode 100644
index 0000000..a835329
--- /dev/null
+++ b/src/sqlite/Makefile.am
@@ -0,0 +1,52 @@
+noinst_LTLIBRARIES = \
+ libsqlite.la
+
+KDE_CFLAGS = \
+ -w
+
+libsqlite_la_CFLAGS = \
+ $(all_includes) \
+ -DTHREADSAFE=1 \
+ -DHAVE_USLEEP=1
+
+libsqlite_la_LDFLAGS = \
+ $(LIBPTHREAD)
+
+libsqlite_la_SOURCES = \
+ alter.c \
+ attach.c \
+ auth.c \
+ btree.c \
+ build.c \
+ callback.c \
+ date.c \
+ delete.c \
+ expr.c \
+ func.c \
+ hash.c \
+ insert.c \
+ legacy.c \
+ main.c \
+ opcodes.c \
+ os_unix.c \
+ os_win.c \
+ pager.c \
+ parse.c \
+ pragma.c \
+ prepare.c \
+ printf.c \
+ random.c \
+ select.c \
+ table.c \
+ tokenize.c \
+ trigger.c \
+ update.c \
+ utf.c \
+ util.c \
+ vacuum.c \
+ vdbe.c \
+ vdbeapi.c \
+ vdbeaux.c \
+ vdbemem.c \
+ where.c
+