summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorSlávek Banko <[email protected]>2021-07-26 13:18:27 +0200
committerSlávek Banko <[email protected]>2021-07-26 13:18:27 +0200
commit8c28c84ffaa6a8b1891b5703f5292f3990d990ca (patch)
tree19b6f5d2fb385e63a8c289b4028290130c727755 /CMakeLists.txt
parent59348e1a4bd9c36e827e363c26004fef40e1007d (diff)
downloadklcddimmer-8c28c84ffaa6a8b1891b5703f5292f3990d990ca.tar.gz
klcddimmer-8c28c84ffaa6a8b1891b5703f5292f3990d990ca.zip
Use common rules for build and install documentation and translations.
Signed-off-by: Slávek Banko <[email protected]>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt8
1 files changed, 6 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index d6819dd..329937e 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -69,8 +69,12 @@ set( CMAKE_MODULE_LINKER_FLAGS "${CMAKE_MODULE_LINKER_FLAGS} -Wl,--no-undefined"
##### directories
add_subdirectory( src )
-tde_conditional_add_subdirectory( BUILD_DOC doc )
-tde_conditional_add_subdirectory( BUILD_TRANSLATIONS translations )
+
+
+##### other data ################################
+
+tde_conditional_add_project_docs( BUILD_DOC )
+tde_conditional_add_project_translations( BUILD_TRANSLATIONS )
##### write configure files