summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in208
1 files changed, 0 insertions, 208 deletions
diff --git a/configure.in b/configure.in
deleted file mode 100644
index 9ad0fc4..0000000
--- a/configure.in
+++ /dev/null
@@ -1,208 +0,0 @@
-dnl =======================================================
-dnl FILE: ./admin/configure.in.min
-dnl =======================================================
-
-dnl This file is part of the KDE libraries/packages
-dnl Copyright (C) 2001 Stephan Kulow ([email protected])
-
-dnl This file is free software; you can redistribute it and/or
-dnl modify it under the terms of the GNU Library General Public
-dnl License as published by the Free Software Foundation; either
-dnl version 2 of the License, or (at your option) any later version.
-
-dnl This library is distributed in the hope that it will be useful,
-dnl but WITHOUT ANY WARRANTY; without even the implied warranty of
-dnl MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
-dnl Library General Public License for more details.
-
-dnl You should have received a copy of the GNU Library General Public License
-dnl along with this library; see the file COPYING.LIB. If not, write to
-dnl the Free Software Foundation, Inc., 59 Temple Place - Suite 330,
-dnl Boston, MA 02111-1307, USA.
-
-# Original Author was [email protected]
-# I lifted it in some mater. (Stephan Kulow)
-# I used much code from Janos Farkas
-
-dnl Process this file with autoconf to produce a configure script.
-
-AC_INIT(acinclude.m4) dnl a source file from your sub dir
-
-dnl This is so we can use kde-common
-AC_CONFIG_AUX_DIR(admin)
-
-dnl This ksh/zsh feature conflicts with `cd blah ; pwd`
-unset CDPATH
-
-dnl Checking host/target/build systems, for make, install etc.
-AC_CANONICAL_SYSTEM
-dnl Perform program name transformation
-AC_ARG_PROGRAM
-
-dnl Automake doc recommends to do this only here. (Janos)
-AM_INIT_AUTOMAKE(kompose, 0.5.4) dnl searches for some needed programs
-
-KDE_SET_PREFIX
-
-dnl generate the config header
-AM_CONFIG_HEADER(config.h) dnl at the distribution this done
-
-dnl Checks for programs.
-AC_CHECK_COMPILERS
-AC_ENABLE_SHARED(yes)
-AC_ENABLE_STATIC(no)
-KDE_PROG_LIBTOOL
-
-dnl for NLS support. Call them in this order!
-dnl WITH_NLS is for the po files
-AM_KDE_WITH_NLS
-
-KDE_USE_QT(3.2)
-AC_PATH_KDE
-dnl =======================================================
-dnl FILE: configure.in.in
-dnl =======================================================
-
-#MIN_CONFIG(3.2)
-
-CXXFLAGS="$CXXFLAGS $KDE_DEFAULT_CXXFLAGS"
-dnl PACKAGE set before
-AC_C_BIGENDIAN
-AC_CHECK_KDEMAXPATHLEN
-
-AC_PREREQ(2.52)
-
-X_LIBS="$X_PRE_LIBS $X_LIBS -lXext -lX11 $X_EXTRA_LIBS"
-
-dnl --- XDamage check
-AC_CHECK_HEADER(X11/extensions/Xdamage.h, [
- AC_CHECK_LIB(Xdamage, XDamageQueryExtension, [
- AC_DEFINE(HAVE_XDAMAGE, 1, [Define if you have the XDamage extens
-ion])
- LIB_XDAMAGE="-lXdamage -lXfixes"],, [ -L/usr/X11R6/lib $X_PRE_LIBS $X_LIBS -lXext -lX11 $X_EXTRA_LIBS ])
- ],, [#include <X11/Xlib.h>])
-AC_SUBST(LIB_XDAMAGE)
-
-dnl --- XComposite check
-AC_CHECK_HEADER(X11/extensions/Xcomposite.h, [
- AC_CHECK_LIB(Xcomposite, XCompositeQueryExtension, [
- AC_DEFINE(HAVE_XCOMPOSITE, 1, [Define if you have the XComposite extens
-ion])
- LIB_XCOMPOSITE="-lXcomposite"],, [ -L/usr/X11R6/lib $X_PRE_LIBS $X_LIBS -lXext -lX11 $X_EXTRA_LIBS ])
- ],, [#include <X11/Xlib.h>])
-AC_SUBST(LIB_XCOMPOSITE)
-
-
-# modified kuickshow imlib search
-#
-# checking for Imlib2...
-dnl --- Imlib2 check
-
-AC_DEFUN([KDE_FIND_IMLIB2_CONFIG],
- [AC_MSG_CHECKING([for imlib2-config])
-
-imlib2_config_given=NO
-ac_imlib2_config=""
-
-AC_ARG_WITH(imlib2-config,
-AC_HELP_STRING([--with-imlib2-config=DIR],[directory where "imlib2-config" is located]),
-[ ac_imlib2_config="$withval/imlib2-config"
- imlib2_config_given=yes
-])
-
-if test "$imlib2_config_given" = "yes"; then
- if test ! -r $ac_imlib2_config; then
- AC_MSG_RESULT(wrong file specified)
- ac_imlib2_config=""
- else
- AC_MSG_RESULT($ac_imlib2_config)
- LIB_IMLIB2=`$ac_imlib2_config --libs`
- AC_SUBST(LIB_IMLIB2)
- fi
-else
- ac_imlib2_config=`which imlib2-config 2>/dev/null`
- if test -z "$ac_imlib2_config"; then
- AC_MSG_RESULT(no)
- else
- dummy=`echo "$ac_imlib2_config" | grep '/imlib2-config'`
- if test -z "$dummy"; then
- AC_MSG_RESULT(no)
- ac_imlib2_config=""
- else
- LIB_IMLIB2=`$ac_imlib2_config --libs`
- IMLIB2_CFLAGS=`$ac_imlib2_config --cflags`
- imlib2_config=`echo "$LIB_IMLIB2" | grep lImlib2`
- if test -z "$imlib2_config"; then
- AC_MSG_RESULT(no)
- ac_imlib2_config=""
- else
- AC_SUBST(LIB_IMLIB2)
- AC_SUBST(IMLIB2_CFLAGS)
- AC_MSG_RESULT($ac_imlib2_config)
- fi
- fi
- fi
-fi
-
-])
-
-dnl Check if Imlib2 is installed properly
-KDE_FIND_IMLIB2_CONFIG
-
-if test -z "$ac_imlib2_config"; then
-dnl AC_MSG_ERROR([You need to install Imlib2 1.x from http://www.enlightenment.org/pages/imlib2.html if your distributor doesn't have a package])
- echo imlib2-config not found
- #DO_NOT_COMPILE="$DO_NOT_COMPILE kompose" # maybe one day we'll be in KDE, so I'll leave this here :)
-fi
-KDE_CREATE_SUBDIRSLIST
-AC_CONFIG_FILES([ Makefile ])
-AC_CONFIG_FILES([ doc/Makefile ])
-AC_CONFIG_FILES([ doc/en/Makefile ])
-AC_CONFIG_FILES([ po/Makefile ])
-AC_CONFIG_FILES([ src/Makefile ])
-AC_OUTPUT
-# Check if KDE_SET_PREFIX was called, and --prefix was passed to configure
-if test -n "$kde_libs_prefix" -a -n "$given_prefix"; then
- # And if so, warn when they don't match
- if test "$kde_libs_prefix" != "$given_prefix"; then
- # And if kde doesn't know about the prefix yet
- echo ":"`tde-config --path exe`":" | grep ":$given_prefix/bin/:" 2>&1 >/dev/null
- if test $? -ne 0; then
- echo ""
- echo "Warning: you chose to install this package in $given_prefix,"
- echo "but KDE was found in $kde_libs_prefix."
- echo "For this to work, you will need to tell KDE about the new prefix, by ensuring"
- echo "that TDEDIRS contains it, e.g. export TDEDIRS=$given_prefix:$kde_libs_prefix"
- echo "Then restart KDE."
- echo ""
- fi
- fi
-fi
-
-if test x$GXX = "xyes" -a x$kde_have_gcc_visibility = "xyes" -a x$kde_cv_val_qt_gcc_visibility_patched = "xno"; then
- echo ""
- echo "Your GCC supports symbol visibility, but the patch for Qt supporting visibility"
- echo "was not included. Therefore, GCC symbol visibility support remains disabled."
- echo ""
- echo "For better performance, consider including the Qt visibility supporting patch"
- echo "located at:"
- echo ""
- echo "http://bugs.kde.org/show_bug.cgi?id=109386"
- echo ""
- echo "and recompile all of Qt and KDE. Note, this is entirely optional and"
- echo "everything will continue to work just fine without it."
- echo ""
-fi
-
-if test "$all_tests" = "bad"; then
- if test ! "$cache_file" = "/dev/null"; then
- echo ""
- echo "Please remove the file $cache_file after changing your setup"
- echo "so that configure will find the changes next time."
- echo ""
- fi
-else
- echo ""
- echo "Good - your configure finished. Start make now"
- echo ""
-fi