summaryrefslogtreecommitdiffstats
path: root/conduits/timeconduit/Makefile.am
diff options
context:
space:
mode:
authortpearson <tpearson@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2011-02-16 20:17:18 +0000
committertpearson <tpearson@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2011-02-16 20:17:18 +0000
commitcb7eddb91455a69cf66fcd717e91a51ca5e2cfef (patch)
treecf5546e4d7c44370fbe9ca2be937bd254f30ebaa /conduits/timeconduit/Makefile.am
downloadkpilot-cb7eddb91455a69cf66fcd717e91a51ca5e2cfef.tar.gz
kpilot-cb7eddb91455a69cf66fcd717e91a51ca5e2cfef.zip
Moved kpilot from kdepim to applications, as the core Trinity libraries should not contain hardware-dependent software
git-svn-id: svn://anonsvn.kde.org/home/kde/branches/trinity/applications/kpilot@1221127 283d02a7-25f6-0310-bc7c-ecb5cbfe19da
Diffstat (limited to 'conduits/timeconduit/Makefile.am')
-rw-r--r--conduits/timeconduit/Makefile.am22
1 files changed, 22 insertions, 0 deletions
diff --git a/conduits/timeconduit/Makefile.am b/conduits/timeconduit/Makefile.am
new file mode 100644
index 0000000..6a58716
--- /dev/null
+++ b/conduits/timeconduit/Makefile.am
@@ -0,0 +1,22 @@
+### Makefile for the time conduit
+###
+### The time conduit is Copyright (C) 2002 by Reinhold Kainhofer
+
+INCLUDES= $(PISOCK_INCLUDE) -I$(top_srcdir)/kpilot/lib $(all_includes)
+METASOURCES = AUTO
+
+servicedir = $(kde_servicesdir)
+service_DATA = time_conduit.desktop
+
+kde_module_LTLIBRARIES = conduit_time.la
+
+
+conduit_time_la_SOURCES = timeConduitSettings.kcfgc \
+ time-factory.cc \
+ time-setup.cc \
+ time-conduit.cc \
+ time-setup_dialog.ui
+conduit_time_la_LDFLAGS = -module $(KDE_PLUGIN) $(all_libraries)
+conduit_time_la_LIBADD = ../../lib/libkpilot.la $(LIB_KDEUI)
+
+kde_kcfg_DATA = timeconduit.kcfg