summaryrefslogtreecommitdiffstats
path: root/tests/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/CMakeLists.txt')
-rw-r--r--tests/CMakeLists.txt18
1 files changed, 9 insertions, 9 deletions
diff --git a/tests/CMakeLists.txt b/tests/CMakeLists.txt
index b38883c..ca18a0e 100644
--- a/tests/CMakeLists.txt
+++ b/tests/CMakeLists.txt
@@ -9,27 +9,27 @@ add_definitions( -DKDESRCDIR=\\"${CMAKE_CURRENT_SOURCE_DIR}\\" )
set(testconstants_SRCS testconstants.cc)
-kde3_add_executable(testconstants ${testconstants_SRCS})
+trinity_add_executable(testconstants ${testconstants_SRCS})
target_link_libraries(testconstants kpilot ${QT_LIBRARIES})
add_test(testconstants ${EXECUTABLE_OUTPUT_PATH}/testconstants)
set(testcategories_SRCS testcategories.cc)
-kde3_add_executable(testcategories ${testcategories_SRCS})
+trinity_add_executable(testcategories ${testcategories_SRCS})
target_link_libraries(testcategories kpilot ${QT_LIBRARIES})
add_test(testcategories ${EXECUTABLE_OUTPUT_PATH}/testcategories)
set(testaddresses_SRCS testaddress.cc)
-kde3_add_executable(testaddresses ${testaddresses_SRCS})
+trinity_add_executable(testaddresses ${testaddresses_SRCS})
target_link_libraries(testaddresses kpilot ${QT_LIBRARIES})
add_test(testaddresses ${EXECUTABLE_OUTPUT_PATH}/testaddresses)
set(testdatebook_SRCS testdatebook.cc)
-kde3_add_executable(testdatebook ${testdatebook_SRCS})
+trinity_add_executable(testdatebook ${testdatebook_SRCS})
target_link_libraries(testdatebook kpilot ${QT_LIBRARIES})
add_test(testdatebook ${EXECUTABLE_OUTPUT_PATH}/testdatebook)
set(testidmapper_SRCS testidmapper.cc)
-kde3_add_executable(testidmapper ${testidmapper_SRCS})
+trinity_add_executable(testidmapper ${testidmapper_SRCS})
target_link_libraries(testidmapper kpilot ${QT_LIBRARIES})
add_test(testidmapper ${EXECUTABLE_OUTPUT_PATH}/testidmapper)
@@ -37,9 +37,9 @@ if (HAVE_CALENDARLOCAL_H)
set(importdatebook_SRCS importdatebook.cc)
set(exportdatebook_SRCS exportdatebook.cc)
set(mergecalendars_SRCS mergecalendars.cc)
- kde3_add_executable(importdatebook ${importdatebook_SRCS})
- kde3_add_executable(exportdatebook ${exportdatebook_SRCS})
- kde3_add_executable(mergecalendars ${mergecalendars_SRCS})
+ trinity_add_executable(importdatebook ${importdatebook_SRCS})
+ trinity_add_executable(exportdatebook ${exportdatebook_SRCS})
+ trinity_add_executable(mergecalendars ${mergecalendars_SRCS})
target_link_libraries(importdatebook kpilot ${QT_LIBRARIES} kcal)
target_link_libraries(exportdatebook kpilot ${QT_LIBRARIES} kcal)
target_link_libraries(mergecalendars ${QT_LIBRARIES} kcal)
@@ -49,7 +49,7 @@ if (HAVE_CALENDARLOCAL_H)
endif (HAVE_CALENDARLOCAL_H)
set(importaddresses_SRCS importaddresses.cc)
-kde3_add_executable(importaddresses ${importaddresses_SRCS})
+trinity_add_executable(importaddresses ${importaddresses_SRCS})
target_link_libraries(importaddresses kpilot ${QT_LIBRARIES} kabc kabc_file)
add_test(importaddresses ${EXECUTABLE_OUTPUT_PATH}/importaddresses)