summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMichele Calgaro <[email protected]>2024-10-31 22:50:43 +0900
committerMichele Calgaro <[email protected]>2024-11-12 10:58:18 +0900
commitd8d55853dcf9aae732bb266ec766c6d10f5bf7ff (patch)
treee2aed68bb901a578e5231d8800f1facda3e458db /CMakeLists.txt
parentec41c8e01cf99fe82118d8c739da6a498ee7afb4 (diff)
downloadkrecipes-d8d55853dcf9aae732bb266ec766c6d10f5bf7ff.tar.gz
krecipes-d8d55853dcf9aae732bb266ec766c6d10f5bf7ff.zip
CMake conversion
Signed-off-by: Michele Calgaro <[email protected]> (cherry picked from commit 2c316e3037228223164adf5cd3446cf47f1744a4)
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt91
1 files changed, 91 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
new file mode 100644
index 0000000..e79b122
--- /dev/null
+++ b/CMakeLists.txt
@@ -0,0 +1,91 @@
+############################################
+# #
+# Improvements and feedbacks are welcome #
+# #
+# This file is released under GPL >= 3 #
+# #
+############################################
+
+
+##### set project version ########################
+
+include( TDEVersion )
+cmake_minimum_required( VERSION ${TDE_CMAKE_MINIMUM_VERSION} )
+tde_set_project_version( )
+
+
+#### general package setup
+
+project( krecipes )
+
+
+#### include essential cmake modules
+
+include( FindPkgConfig )
+include( CheckSymbolExists )
+include( CheckIncludeFile )
+include( CheckLibraryExists )
+include( CheckCSourceCompiles )
+include( CheckCXXSourceCompiles )
+
+
+#### include our cmake modules
+
+include( TDEMacros )
+
+
+##### setup install paths
+
+include( TDESetupPaths )
+tde_setup_paths( )
+
+
+##### optional stuff
+
+option( WITH_ALL_OPTIONS "Enable all optional support" OFF )
+option( WITH_MYSQL "Build MySQL backend support" ${WITH_ALL_OPTIONS} )
+option( WITH_POSTGRESQL "Build PostgreSQL backend support" ${WITH_ALL_OPTIONS} )
+option( WITH_SQLITE3 "Build SQLite3 backend support" ${WITH_ALL_OPTIONS} )
+
+option( WITH_GCC_VISIBILITY "Enable fvisibility and fvisibility-inlines-hidden" ${WITH_ALL_OPTIONS} )
+
+
+##### user requested modules
+
+option( BUILD_ALL "Build all" ON )
+option( BUILD_DOC "Build documentation" ${BUILD_ALL} )
+option( BUILD_TRANSLATIONS "Build translations" ${BUILD_ALL} )
+
+
+##### configure checks
+
+include( ConfigureChecks.cmake )
+
+
+###### global compiler settings
+
+add_definitions( -DHAVE_CONFIG_H )
+
+set( CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} ${TQT_CXX_FLAGS}" )
+set( CMAKE_SHARED_LINKER_FLAGS "${CMAKE_SHARED_LINKER_FLAGS} -Wl,--no-undefined" )
+set( CMAKE_MODULE_LINKER_FLAGS "${CMAKE_MODULE_LINKER_FLAGS} -Wl,--no-undefined" )
+
+
+##### directories
+
+add_subdirectory( data )
+add_subdirectory( icons )
+add_subdirectory( layouts )
+add_subdirectory( pics )
+add_subdirectory( src )
+
+
+##### other data ################################
+
+tde_conditional_add_project_docs( BUILD_DOC )
+tde_conditional_add_project_translations( BUILD_TRANSLATIONS )
+
+
+##### write configure files
+
+configure_file( config.h.cmake config.h @ONLY )