summaryrefslogtreecommitdiffstats
path: root/src/backends/MySQL/Makefile.am
diff options
context:
space:
mode:
authorMichele Calgaro <[email protected]>2024-10-13 11:56:14 +0900
committerMichele Calgaro <[email protected]>2024-10-21 09:29:11 +0900
commit0c8ed6c9a4000af8f48581a81c4b5c2f5b9fd502 (patch)
tree10f9d3223f0a0904a0748a28ca44da52ee1092b7 /src/backends/MySQL/Makefile.am
parent7d5ba3180a82a0827c1fbd6dc93a2abf4f882c37 (diff)
downloadkrecipes-0c8ed6c9a4000af8f48581a81c4b5c2f5b9fd502.tar.gz
krecipes-0c8ed6c9a4000af8f48581a81c4b5c2f5b9fd502.zip
Rearrange folders structure to remove unnecessary 'krecipes' second level subfolder
Signed-off-by: Michele Calgaro <[email protected]>
Diffstat (limited to 'src/backends/MySQL/Makefile.am')
-rw-r--r--src/backends/MySQL/Makefile.am18
1 files changed, 18 insertions, 0 deletions
diff --git a/src/backends/MySQL/Makefile.am b/src/backends/MySQL/Makefile.am
new file mode 100644
index 0000000..7134130
--- /dev/null
+++ b/src/backends/MySQL/Makefile.am
@@ -0,0 +1,18 @@
+## Makefile.am for krecipes
+
+# this is the program that gets installed. it's name is used for all
+# of the other Makefile.am variables
+
+# set the include path for X, tqt and TDE
+INCLUDES = -I$(srcdir) -I$(srcdir)/.. -I$(srcdir)/../.. $(all_includes)
+
+
+# Instructions for building the convenience library
+noinst_LTLIBRARIES=libkrecmysql.la
+libkrecmysql_la_SOURCES=mysqlrecipedb.cpp
+libkrecmysql_la_METASOURCES=AUTO
+
+
+#the library search path.
+libkrecmysql_la_LDFLAGS = $(KDE_RPATH) $(all_libraries)
+