summaryrefslogtreecommitdiffstats
path: root/src/importers/Makefile.am
diff options
context:
space:
mode:
authorMichele Calgaro <[email protected]>2024-10-13 11:56:14 +0900
committerMichele Calgaro <[email protected]>2024-10-29 21:58:42 +0900
commit2879ff70be9271550477982a1a6371714db38562 (patch)
treec2054149dba923ab080fe7093432c7663a990111 /src/importers/Makefile.am
parent3eb38d2556f676d1027746f20bf12a1dd74451ef (diff)
downloadkrecipes-2879ff70be9271550477982a1a6371714db38562.tar.gz
krecipes-2879ff70be9271550477982a1a6371714db38562.zip
Rearrange folders structure to remove unnecessary 'krecipes' second level subfolder
Signed-off-by: Michele Calgaro <[email protected]> (cherry picked from commit 0c8ed6c9a4000af8f48581a81c4b5c2f5b9fd502)
Diffstat (limited to 'src/importers/Makefile.am')
-rw-r--r--src/importers/Makefile.am15
1 files changed, 15 insertions, 0 deletions
diff --git a/src/importers/Makefile.am b/src/importers/Makefile.am
new file mode 100644
index 0000000..28ab637
--- /dev/null
+++ b/src/importers/Makefile.am
@@ -0,0 +1,15 @@
+## Makefile.am for krecipes
+
+# this is the program that gets installed. it's name is used for all
+# of the other Makefile.am variables
+
+# set the include path for X, tqt and TDE
+INCLUDES = -I$(srcdir)/.. -I$(srcdir)/../backends $(all_includes)
+
+noinst_LTLIBRARIES=libkrecipesimporters.la
+libkrecipesimporters_la_SOURCES = mx2importer.cpp mmfimporter.cpp mxpimporter.cpp nycgenericimporter.cpp recipemlimporter.cpp baseimporter.cpp kreimporter.cpp rezkonvimporter.cpp kredbimporter.cpp
+libkrecipesimporters_la_METASOURCES=AUTO
+
+#the library search path.
+libkrecipesimporters_la_LDFLAGS = $(KDE_RPATH) $(all_libraries)
+noinst_HEADERS = kreimporter.h