summaryrefslogtreecommitdiffstats
path: root/src/backends/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/backends/Makefile.am')
-rw-r--r--src/backends/Makefile.am42
1 files changed, 42 insertions, 0 deletions
diff --git a/src/backends/Makefile.am b/src/backends/Makefile.am
new file mode 100644
index 0000000..d9732a0
--- /dev/null
+++ b/src/backends/Makefile.am
@@ -0,0 +1,42 @@
+## Makefile.am for krecipes
+
+# this is the program that gets installed. it's name is used for all
+# of the other Makefile.am variables
+
+# set the include path for X, tqt and TDE
+INCLUDES = -I$(srcdir) -I$(srcdir)/.. $(all_includes)
+
+# Check for optional database libs
+
+
+if link_lib_SQLITE
+sqlite_subdirs=SQLite
+sqlite_libs=SQLite/libkrecsqlite.la
+endif
+
+if link_lib_MYSQL
+mysql_subdirs=MySQL
+mysql_libs=MySQL/libkrecmysql.la
+endif
+
+if link_lib_POSTGRESQL
+psql_subdirs=PostgreSQL
+psql_libs=PostgreSQL/libkrecpsql.la
+endif
+
+# Optional subdirectories
+
+SUBDIRS=$(sqlite_subdirs) $(mysql_subdirs) $(psql_subdirs)
+
+# Instructions for building the convenience library
+noinst_LTLIBRARIES=libkrecipesdbs.la
+libkrecipesdbs_la_SOURCES=recipedb.cpp qsqlrecipedb.cpp progressinterface.cpp
+libkrecipesdbs_la_METASOURCES=AUTO
+
+libkrecipesdbs_la_LIBADD= $(mysql_libs) $(sqlite_libs) $(psql_libs)
+
+#the library search path.
+libkrecipesdbs_la_LDFLAGS = $(KDE_RPATH) $(all_libraries)
+
+#install the following headers
+# include_HEADERS = recipedb.h