summaryrefslogtreecommitdiffstats
path: root/translations/messages/CMakeLists.txt
diff options
context:
space:
mode:
authorgregory guy <[email protected]>2020-05-26 16:03:50 +0200
committerSlávek Banko <[email protected]>2020-05-26 16:09:15 +0200
commitc4545b808eeaf65ac9aaae94a78ea4cf4f9ea96f (patch)
treec406decd8007087f650fcc468970428fae334ba3 /translations/messages/CMakeLists.txt
parent5cad60063799de1846011f1fd5c6023166df9d28 (diff)
downloadkscope-c4545b808eeaf65ac9aaae94a78ea4cf4f9ea96f.tar.gz
kscope-c4545b808eeaf65ac9aaae94a78ea4cf4f9ea96f.zip
Move translations to a new directory layout.
Add support for LINGUAS for listing translations to install. Signed-off-by: gregory guy <[email protected]> Signed-off-by: Slávek Banko <[email protected]> (cherry picked from commit 51db3dd2a0528687837beede00b1522ebb8518fe)
Diffstat (limited to 'translations/messages/CMakeLists.txt')
-rw-r--r--translations/messages/CMakeLists.txt14
1 files changed, 14 insertions, 0 deletions
diff --git a/translations/messages/CMakeLists.txt b/translations/messages/CMakeLists.txt
new file mode 100644
index 0000000..75c89f8
--- /dev/null
+++ b/translations/messages/CMakeLists.txt
@@ -0,0 +1,14 @@
+file( GLOB_RECURSE po_files RELATIVE ${CMAKE_CURRENT_SOURCE_DIR} *.po )
+string( REGEX REPLACE "[ \r\n\t]+" ";" _linguas "$ENV{LINGUAS}" )
+
+foreach( _po ${po_files} )
+ get_filename_component( _lang ${_po} NAME_WE )
+ if( "${_linguas}" MATCHES "^;*$" OR ";${_linguas};" MATCHES ";${_lang};" )
+ if( "${_po}" MATCHES "^([^/]*)/.*" )
+ string( REGEX REPLACE "^([^/]*)/.*" "\\1" _component "${_po}" )
+ else( )
+ set( _component "${PROJECT_NAME}" )
+ endif( )
+ tde_create_translation( FILES ${_po} LANG ${_lang} OUTPUT_NAME ${_component} )
+ endif( )
+endforeach( )