summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorgregory guy <[email protected]>2020-02-12 14:02:24 +0100
committergregory guy <[email protected]>2020-02-12 14:02:24 +0100
commit92482b762101fc6e18740ba34ffb688e77ea8cfa (patch)
tree6d304786240333667806de10a6fa9ac891c6366e /CMakeLists.txt
parentaed1d05ef9ba6f0389000f1e1f9652848e26dea7 (diff)
downloadkvkbd-92482b762101fc6e18740ba34ffb688e77ea8cfa.tar.gz
kvkbd-92482b762101fc6e18740ba34ffb688e77ea8cfa.zip
Drop automake build support.
Add basic cmake build instructions. Delete empty file NEWS, TODO and ChangeLog. Delete empty folder "templates". Add detection for the XTest library. Move the kvkbd.desktop file into XDG_APPS_INSTALL_DIR directory, see TDE/tde#26 . Some cosmetics. Signed-off-by: gregory guy <[email protected]>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt8
1 files changed, 4 insertions, 4 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index a718b15..bcfc98a 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -41,15 +41,15 @@ tde_setup_paths( )
##### optional stuff
-option( WITH_ALL_OPTIONS "Enable all optional support" OFF )
+option( WITH_ALL_OPTIONS "Enable all optional support" OFF )
option( WITH_GCC_VISIBILITY "Enable fvisibility and fvisibility-inlines-hidden" ${WITH_ALL_OPTIONS} )
##### user requested modules
-option( BUILD_ALL "Build all" ON )
-option( BUILD_DOC "Build documentation" ${BUILD_ALL} )
-option( BUILD_TRANSLATIONS "Build translations" ${BUILD_ALL} )
+option( BUILD_ALL "Build all" OFF )
+option( BUILD_DOC "Build documentation" ${BUILD_ALL} )
+option( BUILD_TRANSLATIONS "Build translations" ${BUILD_ALL} )
##### configure checks