summaryrefslogtreecommitdiffstats
path: root/translations/messages/CMakeLists.txt
diff options
context:
space:
mode:
authorSlávek Banko <[email protected]>2020-05-03 10:23:34 +0200
committerSlávek Banko <[email protected]>2020-05-03 10:23:34 +0200
commit4a8dc3c4bc293d0b40adc6f138f0da0dc75c7a71 (patch)
tree08f7327d710292140b948e2fe8fcfd784fc58d73 /translations/messages/CMakeLists.txt
parent3be483df2a3d02e0774c218910232ce742b6dc78 (diff)
downloadkvkbd-4a8dc3c4bc293d0b40adc6f138f0da0dc75c7a71.tar.gz
kvkbd-4a8dc3c4bc293d0b40adc6f138f0da0dc75c7a71.zip
Move translations to a new directory layout.
Add support for LINGUAS for listing translations to install. Signed-off-by: Slávek Banko <[email protected]>
Diffstat (limited to 'translations/messages/CMakeLists.txt')
-rw-r--r--translations/messages/CMakeLists.txt14
1 files changed, 14 insertions, 0 deletions
diff --git a/translations/messages/CMakeLists.txt b/translations/messages/CMakeLists.txt
new file mode 100644
index 0000000..75c89f8
--- /dev/null
+++ b/translations/messages/CMakeLists.txt
@@ -0,0 +1,14 @@
+file( GLOB_RECURSE po_files RELATIVE ${CMAKE_CURRENT_SOURCE_DIR} *.po )
+string( REGEX REPLACE "[ \r\n\t]+" ";" _linguas "$ENV{LINGUAS}" )
+
+foreach( _po ${po_files} )
+ get_filename_component( _lang ${_po} NAME_WE )
+ if( "${_linguas}" MATCHES "^;*$" OR ";${_linguas};" MATCHES ";${_lang};" )
+ if( "${_po}" MATCHES "^([^/]*)/.*" )
+ string( REGEX REPLACE "^([^/]*)/.*" "\\1" _component "${_po}" )
+ else( )
+ set( _component "${PROJECT_NAME}" )
+ endif( )
+ tde_create_translation( FILES ${_po} LANG ${_lang} OUTPUT_NAME ${_component} )
+ endif( )
+endforeach( )