summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in28
1 files changed, 26 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index ba44d56..d7aeaf9 100644
--- a/configure.in
+++ b/configure.in
@@ -101,13 +101,37 @@ AC_SUBST(ART_SIZEOF_INT, $ac_cv_sizeof_int)
AC_CHECK_SIZEOF(long)
AC_SUBST(ART_SIZEOF_LONG, $ac_cv_sizeof_long)
+if test $ART_SIZEOF_CHAR -eq 1; then
+ AC_SUBST( ART_U8_TYPE, "unsigned char" )
+else
+ echo 1>&2 "sizeof(char) != 1"
+ exit 1
+fi
+
+if test $ART_SIZEOF_SHORT -eq 2; then
+ AC_SUBST( ART_U16_TYPE, "unsigned short" )
+else
+ echo 1>&2 "sizeof(short) != 2"
+ exit 2
+fi
+
+if test $ART_SIZEOF_INT -eq 4; then
+ AC_SUBST( ART_U32_TYPE, "unsigned int" )
+else
+ if test $ART_SIZEOF_LONG -eq 4; then
+ AC_SUBST( ART_U32_TYPE, "unsigned long" )
+ else
+ echo 1>&2 "sizeof(int) != 4 and sizeof(long) != 4"
+ exit 3
+ fi
+fi
+
AC_CONFIG_FILES([
+art_config.h
libart-features.h
Makefile
libart-2.0.pc
libart-2.0-uninstalled.pc
libart-zip])
-AC_CONFIG_FILES([gen_art_config.sh],[chmod +x gen_art_config.sh])
-
AC_OUTPUT