summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorgregory guy <[email protected]>2020-05-02 15:27:18 +0200
committerMichele Calgaro <[email protected]>2020-05-04 22:49:22 +0900
commit9560202d56a51045f54eb1a92029de2f55d4a405 (patch)
treeef7815ac7819177950165dbe5b0854f8d3489d80 /CMakeLists.txt
parent3e0e33acb7bb9ae94059e38dc50406a5df7bd3ec (diff)
downloadlibtdeldap-9560202d56a51045f54eb1a92029de2f55d4a405.tar.gz
libtdeldap-9560202d56a51045f54eb1a92029de2f55d4a405.zip
Drop automake build support.
Add basic cmake build instructions. Add basic README file. Delete empty folders doc and po. Delete empty files ChangeLog, NEWS and TODO. Some cosmetics. Signed-off-by: gregory guy <[email protected]> (cherry picked from commit edec9f9049b58e8b3cd0ca2c4560857404fdcc5a)
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt9
1 files changed, 5 insertions, 4 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 2cae584..a4baaf3 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -41,15 +41,15 @@ tde_setup_paths( )
##### optional stuff
-option( WITH_ALL_OPTIONS "Enable all optional support" OFF )
+option( WITH_ALL_OPTIONS "Enable all optional support" OFF )
option( WITH_GCC_VISIBILITY "Enable fvisibility and fvisibility-inlines-hidden" ${WITH_ALL_OPTIONS} )
##### user requested modules
-option( BUILD_ALL "Build all" ON )
-option( BUILD_DOC "Build documentation" ${BUILD_ALL} )
-option( BUILD_TRANSLATIONS "Build translations" ${BUILD_ALL} )
+#option( BUILD_ALL "Build all" ON )
+#option( BUILD_DOC "Build documentation" ${BUILD_ALL} )
+#option( BUILD_TRANSLATIONS "Build translations" ${BUILD_ALL} )
##### user defined options
@@ -76,6 +76,7 @@ set( CMAKE_MODULE_LINKER_FLAGS "${CMAKE_MODULE_LINKER_FLAGS} -Wl,--no-undefined"
##### directories
add_subdirectory( src )
+
#tde_conditional_add_subdirectory( BUILD_DOC doc )
#tde_conditional_add_subdirectory( BUILD_TRANSLATIONS po )