summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authordscho <dscho>2004-06-07 17:47:54 +0000
committerdscho <dscho>2004-06-07 17:47:54 +0000
commit00901a2eb9ec569157fad8a531a1de037ac0e2de (patch)
tree9588d5402031524e297ebcded797fae13c23f966 /configure.ac
parentc7730d9bad3add8dc02fb1ebbc9c65a35415d43b (diff)
downloadlibtdevnc-00901a2eb9ec569157fad8a531a1de037ac0e2de.tar.gz
libtdevnc-00901a2eb9ec569157fad8a531a1de037ac0e2de.zip
add vnc2mpg, a program which makes a movie from a VNC desktop using FFMPEG
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 7 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 0ea9ebb..ebd8e69 100644
--- a/configure.ac
+++ b/configure.ac
@@ -33,6 +33,12 @@ AH_TEMPLATE(SDL_CONFIG, [Use sdl-config (for SDLvncviewer)])
AC_ARG_WITH(sdl,
[ --with-sdl use sdl-config],
, [ with_sdl=yes ])
+AH_TEMPLATE(FFMPEG, [Use ffmpeg (for vnc2mpg)])
+AC_ARG_WITH(ffmpeg,
+ [ --with-ffmpeg=dir set ffmpeg home directory],,)
+#AM_DEFINE(FFMPEG, "$with_ffmpeg")
+AC_SUBST(with_ffmpeg)
+AM_CONDITIONAL(WITH_FFMPEG, test ! -z "$with_ffmpeg")
# Checks for X libraries
HAVE_X="false"
@@ -155,7 +161,7 @@ AC_CONFIG_FILES([Makefile
libvncclient/Makefile
client_examples/Makefile
test/Makefile
- libvncserver.spec
+ LibVNCServer.spec
libvncserver-config])
AC_OUTPUT
chmod a+x ./libvncserver-config