summaryrefslogtreecommitdiffstats
path: root/libvncclient/Makefile.am
diff options
context:
space:
mode:
authordscho <dscho>2003-07-28 12:01:07 +0000
committerdscho <dscho>2003-07-28 12:01:07 +0000
commit13b358fed1b89a7a7f8c47bc175dcb3ccae1e39b (patch)
tree8ca17b27e8b953403b93625381aa162d734c4287 /libvncclient/Makefile.am
parenteef408c1d84c7aaceb9732dd9a7e216886d2c2f8 (diff)
downloadlibtdevnc-13b358fed1b89a7a7f8c47bc175dcb3ccae1e39b.tar.gz
libtdevnc-13b358fed1b89a7a7f8c47bc175dcb3ccae1e39b.zip
fixed maxRectsPerUpdate with Tight encoding bug; some autoconfing; stderr should not be used in a library (use rfbLog instead)
Diffstat (limited to 'libvncclient/Makefile.am')
-rw-r--r--libvncclient/Makefile.am18
1 files changed, 18 insertions, 0 deletions
diff --git a/libvncclient/Makefile.am b/libvncclient/Makefile.am
new file mode 100644
index 0000000..78b5620
--- /dev/null
+++ b/libvncclient/Makefile.am
@@ -0,0 +1,18 @@
+CFLAGS=-g -I.. -I. -Wall
+
+libvncclient_a_SOURCES=cursor.c listen.c rfbproto.c sockets.c vncviewer.c
+
+rfbproto.o: rfbproto.c corre.c hextile.c rre.c tight.c zlib.c
+
+EXTRA_DIST=corre.c hextile.c rre.c tight.c zlib.c
+
+$(libvncclient_a_OBJECTS): ../rfb/rfbclient.h
+
+lib_LIBRARIES=libvncclient.a
+
+client_test_SOURCES=client_test.c
+
+noinst_PROGRAMS=client_test
+
+#client_test_LDADD=libvncclient.a ../libvncserver.a
+client_test_LDADD=libvncclient.a