summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac14
1 files changed, 14 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index e7db854..1bdef8c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -831,6 +831,20 @@ if test "$build_x11vnc" = "yes"; then
# configure.ac:690: required file `x11vnc/Makefile.in' not found
#
AC_CONFIG_FILES([x11vnc/Makefile x11vnc/misc/Makefile x11vnc/misc/turbovnc/Makefile])
+
+ if test ! -z "$with_system_libvncserver" -a "x$with_system_libvncserver" != "xno"; then
+ # need to move local tarball rfb headers aside:
+ hdrs="rfb.h rfbclient.h rfbproto.h rfbregion.h rfbint.h"
+ echo "with-system-libvncserver: moving aside headers $hdrs"
+ for hdr in $hdrs
+ do
+ if test -f "rfb/$hdr"; then
+ echo "with-system-libvncserver: moving rfb/$hdr to rfb/$hdr.ORIG"
+ mv rfb/$hdr rfb/$hdr.ORIG
+ fi
+ done
+ echo "with-system-libvncserver: *NOTE* move them back manually to start over."
+ fi
fi
AC_CONFIG_COMMANDS([chmod-libvncserver-config],[chmod a+x libvncserver-config])