summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 4 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 147be1f..5c4bfba 100644
--- a/configure.ac
+++ b/configure.ac
@@ -103,6 +103,10 @@ AC_CHECK_LIB(nsl,gethostbyname)
AC_CHECK_LIB(socket,socket)
AC_CHECK_FUNCS([ftime gethostbyname gethostname gettimeofday inet_ntoa memmove memset mkfifo select socket strchr strcspn strdup strerror strstr setsid])
+# check, if shmget is in cygipc.a
+AC_CHECK_LIB(cygipc,shmget)
+AM_CONDITIONAL(CYGIPC, test "$HAVE_CYGIPC" = "true")
+
# Check if /dev/vcsa1 exists, if so, define LINUX
AM_CONDITIONAL(LINUX, test -c /dev/vcsa1)