summaryrefslogtreecommitdiffstats
path: root/test/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'test/Makefile.am')
-rw-r--r--test/Makefile.am6
1 files changed, 3 insertions, 3 deletions
diff --git a/test/Makefile.am b/test/Makefile.am
index c2d04c4..1084cb8 100644
--- a/test/Makefile.am
+++ b/test/Makefile.am
@@ -1,14 +1,14 @@
DEFINES=-I.. -g -Wall
+LDADD = ../libvncserver/libvncserver.a ../libvncclient/libvncclient.a @WSOCKLIB@
if HAVE_LIBPTHREAD
BACKGROUND_TEST=blooptest
+ENCODINGS_TEST=encodingstest
endif
copyrecttest_LDADD=$(LDADD) -lm
-noinst_PROGRAMS=encodingstest cargstest copyrecttest $(BACKGROUND_TEST)
-
-LDADD = ../libvncserver/libvncserver.a ../libvncclient/libvncclient.a
+noinst_PROGRAMS=$(ENCODINGS_TEST) cargstest copyrecttest $(BACKGROUND_TEST)
test: encodingstest cargstest copyrecttest
./encodingstest && ./cargstest