summaryrefslogtreecommitdiffstats
path: root/src/data/app_data/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/data/app_data/CMakeLists.txt')
-rw-r--r--src/data/app_data/CMakeLists.txt17
1 files changed, 17 insertions, 0 deletions
diff --git a/src/data/app_data/CMakeLists.txt b/src/data/app_data/CMakeLists.txt
new file mode 100644
index 0000000..8006211
--- /dev/null
+++ b/src/data/app_data/CMakeLists.txt
@@ -0,0 +1,17 @@
+
+##### application data files
+
+tde_create_translated_desktop(
+ SOURCE piklab.desktop
+ DESTINATION ${XDG_APPS_INSTALL_DIR}
+)
+
+install(
+ FILES piklabui.rc hexeditorpartui.rc
+ DESTINATION ${DATA_INSTALL_DIR}/piklab
+)
+
+tde_create_translated_desktop(
+ SOURCE x-piklab.desktop
+ DESTINATION ${MIME_INSTALL_DIR}/application
+)