summaryrefslogtreecommitdiffstats
path: root/gui/CMakeLists.txt
diff options
context:
space:
mode:
authorMichele Calgaro <[email protected]>2021-10-30 12:06:43 +0900
committerMichele Calgaro <[email protected]>2021-10-30 12:06:43 +0900
commit28de2ff84f59ac0b173670aa9c5331bc77c1e63f (patch)
tree43dcf0f461ee5552100b648e38979982c971597d /gui/CMakeLists.txt
downloadpolkit-tqt-28de2ff84f59ac0b173670aa9c5331bc77c1e63f.tar.gz
polkit-tqt-28de2ff84f59ac0b173670aa9c5331bc77c1e63f.zip
Initial import from polkit-qt-1 debian snapshot archive.
https://snapshot.debian.org/package/polkit-qt-1/0.103.0-1/ Signed-off-by: Michele Calgaro <[email protected]>
Diffstat (limited to 'gui/CMakeLists.txt')
-rw-r--r--gui/CMakeLists.txt26
1 files changed, 26 insertions, 0 deletions
diff --git a/gui/CMakeLists.txt b/gui/CMakeLists.txt
new file mode 100644
index 000000000..44abb7582
--- /dev/null
+++ b/gui/CMakeLists.txt
@@ -0,0 +1,26 @@
+include_directories(
+ ${CMAKE_CURRENT_BINARY_DIR}
+ ${CMAKE_CURRENT_SOURCE_DIR}
+)
+
+set(polkit_qt_gui_SRCS
+ polkitqt1-gui-action.cpp
+ polkitqt1-gui-actionbutton.cpp
+ polkitqt1-gui-actionbuttons.cpp
+)
+
+automoc4_add_library(polkit-qt-gui-1 SHARED ${polkit_qt_gui_SRCS})
+
+target_link_libraries(polkit-qt-gui-1
+ ${QT_QTCORE_LIBRARY}
+ ${QT_QTGUI_LIBRARY}
+ ${QT_QTDBUS_LIBRARY}
+ ${POLKIT_LIBRARIES}
+ polkit-qt-core-1
+)
+
+set_target_properties(polkit-qt-gui-1 PROPERTIES VERSION ${POLKITQT-1_LIBRARY_VERSION}
+ SOVERSION ${POLKITQT-1_ABI_VERSION}
+ DEFINE_SYMBOL MAKE_POLKITQT1_LIB)
+
+install(TARGETS polkit-qt-gui-1 ${INSTALL_TARGETS_DEFAULT_ARGS})